Flash Not Firing

My D3100 9s brand new and the flash is not firing at all. The first five or six shots I took the flash worked and now I cannot remember if I changed an obscure setting. I have tried resetting to default. I read a similar thread with this issue here that was not resolved so I am asking again in the hope I do not have to replace my new D3100. I've compared settings with my Dads D5200 and the only difference is that that his flash fires and mine does not. ;)
I'm a little flustered with this, and any help would be great.


  • edited July 2015
    The above youtube video by Yacinus worked for me to repair my D5000 flash not firing. I fixed it on 7-6-2015. Please note that my flash did pop up originally it just didn't fire when up and this fixed that problem. Please note, when removing the back cover I somehow dislodged the tension spring on the opposite side that controls the actual pop up of the flash. It was not easy for me to get this back in the correct place, but my husband who is more mechanically inclined than I was able to get it back and then camera works great. (If your flash will not pop up at all, maybe this spring has come loose. Just a thought for those of you with that problem). Thanks for saving me $300!
  • edited July 2015
    I have a D3100 from my brother. He used it first for a couple of months then gave to me as a gift. When I started to explore with it, the flash didn't fire after some instructions followed in the guide category. Please help as I'm afraid to bring it to the service center. I think I just pressed something that I didn't mean to.
  • edited July 2015
    I would first test by putting it in one of the P, S, A or M modes, say aperture priority, and manually pop the flash up. It should then fire. If the settings are right it will fire as fill flash. If it's set manually or wrong it might produce a bad exposure, but it should at least fire if it's manually popped up. If it does fire, then you do not need more drastic solutions, and most likely need to study settings. If it does not, then you can investigate repair options.

  • edited September 2015
    Hi Folks,

    I'm posting this reply because I had the same issue and I was able to fix it. After watching the video posted above by @YACINUS, I understood what might be the issue here.

    To fix it I tapped (with some force) on the right hand ride of the flash popup (LCD facing you). After 2-3 hard taps I was able to get this flash popup to open.

    Saved me a trip to the Nikon Service Center. I'm disappointed with Nikon quality.

    Good luck to you.
Sign In or Register to comment.