Flash Not Firing

edited January 2013 Posted in » Nikon D3100 Forum
My D3100 9s brand new and the flash is not firing at all. The first five or six shots I took the flash worked and now I cannot remember if I changed an obscure setting. I have tried resetting to default. I read a similar thread with this issue here that was not resolved so I am asking again in the hope I do not have to replace my new D3100. I've compared settings with my Dads D5200 and the only difference is that that his flash fires and mine does not. ;)
I'm a little flustered with this, and any help would be great.


  • edited January 2013
    Can you give us the exact settings the camera was set at when the problem occurred? Let's assume for a minute you have it set to full auto. Even if the flash is up, if the camera determines no flash is needed it won't fire. Same for the preset auto settings. Even if the flash fired and you move five feet to the left and took another shot the flash may or may not fire.
    I also recommend stepping away from the camera and reading the manual. I know the D3100 manual is about as exciting as watching paint dry but the answer to your problem might be in there.
  • edited January 2013
    Well, I am pretty new to photography. The camera was just out of the box, full auto. The camera says subject too dark and then if I press the shutter release half way the flash pops up and focuses but never fires. Right now in a poorly lit room auto says 1/60 f/5.6. Also the exposure bar at the bottom is full to the right +............0||||||||||-. I assume this is bad too. I realise I am probably leaving several things you wanted out; complete novice I know.

  • edited January 2013
    I'm assuming you have the 18-55 kit lens. Let's see if we can get you going.
    Rotate the dial on top to S
    Set Shutter to 1/60. If you can go to 1/100 do it
    Set Auto-ISO 200-3200
    Set white balance to flash
    Pop-up the on camera flash and try it.
  • edited January 2013
    Cheers for the help by the way. I did the above and I see a green dot in the bottom left of the view finder saying it's in focus but it won't go any further.
  • edited January 2013
    OK, I mounted my kit lens and went to the darkest room in my house.
    I think I know what the problem is. When I point the lens to the darkest part of the room, the camera won't auto-focus properly. Leave the aforementioned camera settings alone. What you need to do is focus the lens manually. On the left side of the kit lens is a switch. Set it to M. Manually focus the camera until the green ball on the left stops blinking. It might be kind of a pain but stick with it. Once that ball is solid, take the shot. It should work like it's supposed to.

  • edited January 2013
    Leaves me at the same point. Shutter still does not release.
  • edited January 2013
    When I tried it with the same settings the flash fired. I'll give you the exact settings on my D3100:
    1) The above mentioned settings
    2) Set the auto-focus to AF-C. Look in the manual to change that setting.
    3) Shooting Menu>AF-Area Mode>Viewfinder>Single Point AF
    4) Shooting Menu>Metering>Center Weighted
    Try it in a space with more light. Then we know if it's the ambient lighting or not. I know the D3100 doesn't like to auto-focus when it's really dark, but if I can do it, you can too.
    I think if you keep trying with manual focus you'll get it.
  • edited January 2013
    I truly appreciate your dedication to the cause! I'm really starting to believe my flash is faulty. I am getting a solid green dot and holding it for about 5-6 seconds to no avail, sadly.
  • edited January 2013
    Does anything jump out as blatantly wrong, apart from the time? (picture lacking flash) http://i.imgur.com/QQf25e6.jpg
  • edited January 2013
    Everything on your camera looks normal to me. You said your Dad has a D5200. Does he have an off camera flash for it? This is where I would try an external flash. Does the on-camera flash work in other places? I almost forgot, check this setting:
    Shooting Menu>Built-In-Flash
    Make sure it is set to TTL.
  • edited January 2013
    Unfortunately he does not (he just made the move to DSLR), it's the next thing on the list . I've tried it inside and outside the house all throughout the day. It has not worked at all since last night; the flash that is.

    It is set to TTL and I tried the manual options earlier.
  • edited January 2013
    Well it looks like the flash has crashed and burned. Depending on where you got it, I'd return it and get a replacement.
  • Oh well , 5 flash life span . Solid . Hope the next one does not suffer the same issues .
    Thank you very much for the help either way :)
  • @JasonR - Is your battery fully charged? I know that if it drops below a certain threshold, the flash won't fire.
  • edited January 2013
    @ZekeMenuar - I think Nikon should hire you as part of their support team. :) You ran through about every scenario I could think of. Thanks for assisting @JasonR.
  • edited January 2013
    If it is something as simple as the battery I will both cry and kiss you. I think it is fully charged because the light on the charger was constant (as opposed to flashing). Granted it seemed as if it were a very short charge.
  • edited January 2013
    Glad to do it. Many of the scenarios I see here I've ran through myself, repeatedly.

    It can be really frustrating for raw noobs sometimes. It's nice to have a place where the noobs won't get yelled at by the full-frame guys.

    I miss the good old days of black and white. Get a roll of Tri-X, push to 1600, set shutter to 1/125, check meter, set aperture and go shooting.

  • edited January 2013
    If the camera is straight out of the box you may need to run your battery down (until you have the warning) by using the camera and using the display (which uses up the battery) then charge again. It takes a few charges to get a full charge on a new camera. You also mentioned it did not take long to charge, so there may not be a full charge despite a steady light, hence the above statement from Moose.

    They claim that batteries don't have a memory these days, but a charge after a red warning is a good charge I have found.
  • edited January 2013
    Thanks for the response. I have since run the battery down fully and charged it, but still no change, so it's going back tomorrow.
  • Check this out:
Sign In or Register to comment.