I used to take the photo using canon 1200D.However, as I take the photo today it would shot.what would be the possible reason why it won't take a photo? A month ago someone borrowed my dlsr for weeding and after that my camera has this problem


  • I mean it wouldnt take a photo. battery is okey. when i use display there were no display at all.
  • it just says BUSY when taking a photo
  • edited November 2017
    There are a few circumstances when this happens, but first I would like you to try the following.
    1--- Make sure the lens is connected properly to the camera body and move the switch from AF to MF. Try taking a picture. Did it work?
    2--- If you have another lens or can borrow one try to take a picture with the lens set to AF. Did it work?
    If the answers to 1 + 2 were "Yes - it did work" then your problem is with the first lens.
    If your camera still did not take a picture try the next step.
    3--- Set your camera to 'live view' shooting and try taking a picture. Did it work?
    If the camera worked, then there could be a problem with the autofocus inside the camera.
    These are some things you can try.
    For the lens problem -
    A--- Detach the lens and turn the thin focus ring while listening for any noises like a grinding sound. Not all lenses have full time manual focussing which means if someone turns the thin focus ring while it is switched to AF mode damage can occur.
    B--- Have a look at the contacts on the rear of the lens and on the camera body. Are they worn or dirty? Use a microfibre cloth to gently clean them
    For the autofocus problem I think you are looking at going to a service centre as the fault could lie in the camera body itself.
    Just in case you have not, take the battery out and then replace it. If you can call up the Menu screens, reset the camera to default (you will lose any settings you have made). Also try another memory card if you have one. Sometimes if a card is full the camera tries to write data and says it is busy. The usual reason for this is because someone has tried to take out the card or switched the camera off while it is still writing data. There is a little red warning light on your camera which must go out before you can switch off the camera. Never remove the memory card when the camera is switched on.
    I cannot guarantee my answers will solve your problem, I only offer them as possible solutions.
Sign In or Register to comment.