Card full reading

My T2i is gives me a message of "Card full" and it's completely clear - confirmed on the computer. I put in a brand new one and it's still reading the same. Any suggestions?


  • edited August 2015
    This is a strange one I have not come across before. However, the first thing to try is to reset the camera to its default settings. I only suggest this as you say a new card generates the same message although it means losing any options you have set. In case you are not sure how to do this, the procedure is as follows:
    1) Select any one of P, A, S, M modes - not auto
    2) Press MENU
    3) To the left of the star - 'MY MENU' tab - select settings 3
    4) Scroll down to CLEAR CUSTOM SETTINGS

    Your camera will now revert to the manufacturer's default settings, losing any custom settings you may have made.
    If this does not cure your problem, then I am afraid I'm stumped, but I will continue to research a possible answer.
    Best regards,
  • edited August 2015
    First of all, check the interlock tab. It's easy to move, and it's also possible for the tab to malfunction.

    Try reformatting in the camera. If the camera refuses to do this, I'd suspect the card, either of a bad interlock or just plain bad.
  • edited September 2015
    I would agree with @bruto on this except for the fact that you had tried a different card and received the same error message. As promised, I have spoken to quite a few people about your problem including a Canon engineer. It seems none of them has experienced this particular problem before. They all suggest resetting the camera as I described in my previous post, before biting the bullet and contacting a Canon service center.
Sign In or Register to comment.