Howdy, Stranger!

If you're just starting out in the world of photography and want to learn how to get the most out of your camera, then this forum is your new secret hangout spot!

Take better photos today with my Canon T2i Cheat SheetsCheck 'em out!

Memory Card Problem

edited April 2012 Posted in » Canon T2i Forum
Hey @Moose - I just bought a new T2i about a week ago and I'm already experiencing some problems. I have a PNY 32GB Class 10 memory card. When I turn on my camera it says, "Card cannot be accessed. Reinsert/change the card or format card with camera." I've already tried to format the card on my computer and on the camera. Every time I try it on the camera it says, "Cannot format. Change card." I just want to be able to use my camera. Thanks, Andy

Comments

  • There is a little slider/switch on the card. Check to see if it is in the "locked" mode. On my PNY card, it would be in the "down" position to be locked.
  • edited April 2012
    Thanks for replying. I just checked and it isn't locked.
  • If you can return the card, I would do so and exchange for a new one.
  • Do you have any recommendations?
  • edited April 2012
    I would avoid Transcend. I've not had good luck with those cards before. I use PNY and Kingston SD cards. Both are 16GB Class 10. I've not had any problems using those.

    Another question: When you formatted the card on your PC, did you choose "FAT (Default)" for the File System, and "Default allocation" for the unit size?
  • edited April 2012
    I always use Lexar. Not only does Canon recommend them for the T2i, but many professionals use them as they are well known for reliability. They are a little more expensive than Kingston, but not by much. Regards, PBked
  • @Andy - It sounds like you've done all the appropriate steps to get the card working with your T2i. Just to make sure, I would format your memory card one more time using your PC and make sure you select "FAT32" and uncheck the 'Quick Format' option. If that doesn't fix it, then you've got a memory card issue. As for recommended memory cards, check out my write-up here.
  • it is happening the same thing with me, the only diferrence is that I'm using T3i.
    When I turn on my camera it says, "Card cannot be accessed. Reinsert/change the card or format card with camera." I've already tried 4 differents Cards and it's always the same!
    I check the "locked" mode, I format the card on my Mac and choose FAT (default), but it's still not working!!
    somebody help me please!
  • Thanks for replying. I tried to format the memory card with the settings that you told me to use. But, it's still not working. So I just went ahead and bought a new memory card. I bought the Sandisk Extreme Pro 8GB SDHC card. Hopefully I'll have better luck with this card. Thanks for everything!
  • Andy, did you ever get your issue resolved? I'm receiving the same error.
  • edited June 2014
    I hope this isn't way too late. I had the same problem and just successfully fixed it! I hope you have the same problem.

    A part of my old SD card came off and stayed inside the card slot. It did 2 things.

    1. Prevent the spring action from catching the card. I would push in the card and it wouldn't catch. I had to close the door to keep the card in. It worked fine for about 2 weeks.

    2. After those 2 weeks it would just give me a card error or no card in camera error or a bunch of other laments. I was very sad!

    Then I peeked in with a flashlight and saw a few chunks of blue in the slot. I managed to pull them out with shaking, canned air and smacking. Lo and behold, all was well.

    Here's a photo of the pieces and a 67mm lens cap for scale.

    http://imgur.com/4w8eELQ
Sign In or Register to comment.