Howdy, Stranger!

If you're just starting out in the world of photography and want to learn how to get the most out of your camera, then this forum is your new secret hangout spot!

Take better photos today with my Nikon D5300 Cheat SheetsCheck 'em out!

Old 50mm lens issue with D5300

edited January 26 Posted in » Nikon D5300 Forum
So here is the thing, I have this early 90's 50mm lens from Nikon that fits my D5300, which only lets me shoot with the aperture ring in f/22. If I move the aperture ring on the lens, a message pops up that says: "Lock the aperture ring in the further close position", and it won't shoot unless I put it back to f/22.
Other than that, it works great. It's all manual of course, and it gives me a shorter depth of field. Any idea what might be happening?

Comments

  • edited January 26
    The old AF lenses require the aperture ring to be locked at min, but the camera's aperture control works as it does on all current AF lenses. Remember that in manual mode, you must push down the [+/-] button when turning the wheel. Essentially, except for certain early AF film cameras and a few that allow you to modify the menu, you lock the ring and treat it forever after as a G lens.

    On AF lenses with an aperture ring, make sure when mounting that the aperture ring goes all the way to the minimum, and depresses the little switch on the camera mount. Although it is rarely a problem, I have had an issue early on with the minimum aperture tab colliding with that switch and not pressing it down correctly, causing an error. There is sometimes enough play in the system to allow the lens to lock on and seem all right when it's not actually quite all on. If in doubt, give the switch a little flick with a fingernail when locking the aperture ring. If it gives no error message with the ring locked, you're fine. I solved my problem by very (very, very) lightly burnishing the sharp edge of the minimum aperture tab on the lens, so that it did not dig into the switch.

    When I had this issue and figured it out, I looked on the web for others who had had it, and found a post on this forum, which is how I came to visit here regularly.
  • Thanks a lot! I didn't know about having to press the [+/-] while turning the wheel. Why is that?
  • Because this model camera only has a single rear wheel, it cannot control both aperture and shutter speed without another switch. It's designed to control shutter speed when used alone, and in order to switch to aperture, you hold down the compensation button (there being no compensation in Manual mode). In Aperture priority mode, the wheel does aperture alone, in
    shutter priority it does shutter alone, and in P mode it changes both at once, keeping the exposure value the same but varying the proportion of the two.

    It's sort of arbitrary, of course, but on higher end cameras with two wheels, the rear wheel does shutter speed, so I guess they figured rear/shutter as the default was more consistent.
Sign In or Register to comment.