Howdy, Stranger!

If you're just starting out in the world of photography and want to learn how to get the most out of your camera, then this forum is your new secret hangout spot!

Take better photos today with my Nikon D5100 Cheat SheetsCheck 'em out!

Flash sometimes does not operate

edited February 2016 Posted in » Nikon D5100 Forum
Hi, I'm trying to understand why my flash will not work. It was working before I manipulated some settings working with use features. Battery is charged.

If I set camera to "Auto", flash will pop-up, but will not flash.
Flash indicator on view screen is "Auto".

If I set to "A" (Aperture-priority Auto), flash does not pop-up. "?" indicator is blinking.

I'm thinking I changed a setting while trying different settings to get the feel for the features and some part of the system is turned off.

Any ideas, as I cannot relate to a solution in the manual?

Comments

  • edited February 2016
    If you're in aperture priority mode, you have to manually pop up the flash with the button on the left front of the camera.
  • edited February 2016
    Thanks, but I tried that and forgot to mention earlier. When I operate the shutter there is a pause (timed for lack of light I assume), and then the click; no flash.

    Still in the dark for indoor photos.
  • edited February 2016
    I have had that happen occasionally on the D3200, but it's infrequent and unpredictable, so I have not figured out if it's a fault or a feature, so to speak.

    I think when the flash is set to TTL mode, it can get flummoxed. One thing you might try just for experimenting, is to reset the flash (menu item only on the D3200 at least) to manual. This is not likely to be a good mode for actual use, but when you pop it up, it should fire every time on manual, since it's not using the camera's internal computer at all, just firing. Try setting the camera to A priority, manual flash, and fire a dozen or so shots in different light. They will almost certainly look lousy being flashed at the wrong intensity, but it will tell you in a hurry if the flash is working right. I do a lot of meterless macro shots using a typesetting lens in a microscope adapter, with manual flash, and it's never failed to fire then.

    If you find it's working consistently in manual, then I'd suggest you try resetting the TTL settings. On "Auto" setting, the flash may or may not fire. It will pop up if the initial meter reading suggests that it should, but because its actual operation is at least partially controlled after the shutter opens, it may change its mind if the light level changes.

    You can change the flash settings (but not from TTL to Manual), with the [i] menu. One item there sets red eye, slow sync and rear curtain (the default being the plain lightning bolt - no redeye, regular sync). The second setting is flash compensation, plus or minus, which is regulated with the rear control's up/down arrows. Usually when my TTL flash fails to fire, I find it also failed to take a picture at all, and I just push the button again, and get a good shot.
  • edited February 2016
    Thanks Bruto, I tried the fix you suggested; no flash. I now think there is a problem with the flash and I will take the camera to a Nikon service center when I return home. Thanks to both of you for taking the time to comment.
  • That's too bad. I hope it's just a bad contact. I think the flash has some kind of automatic switch that activates it when it opens.

    As a temporary thing you might try closing it and popping it up a few times to see if it wakes up a glitchy switch.
Sign In or Register to comment.