Howdy, Stranger!

If you're just starting out in the world of photography and want to learn how to get the most out of your camera, then this forum is your new secret hangout spot!

Take better photos today with my Nikon D5100 Cheat SheetsCheck 'em out!

Nikon D5100 Info (i) button

edited October 2014 Posted in » Nikon D5100 Forum
Hi,

I have a Nikon D5100 camera. It's a very good camera and I love it. I have had this camera for 2 years.
Yesterday I took some photo of my children. I pushed the (i) button to get the changeability of any setting in the screen. I changed the focus point to center. After this setting, the (i) button doesn't work. When the screen's light turns off and I press the (i) button, the screen turns on. If I press it again it does nothing.
What's the problem? Does anyone have any idea about this problem? Have I locked the (i) button somehow?
Thank for your help.

Chris

Comments

  • edited October 2014
    It’s important to note that there are 2 info buttons on the camera. It’s rather confusing, I don’t know why Nikon chose to design it like this.

    One is labeled with just an “i" and is located directly to the right of the viewfinder. I suspect this is the button you were referring to.
    The other is labeled “Info” and is located on top of the camera next to the mode dial.

    To turn off the screen, you need to press the “Info” button. This button is specifically for toggling on and off the screen. In general, it’s not necessary to manually turn off the screen unless you’re really into battery conservation. The screen switches off on its own after a while or when you put your eye to the viewfinder.
    (Edit: Actually, the “info” button also toggles through the various overlays when in Live View, but I primarily use it to toggle the screen on and off.)

    The “i" button is used for making setting changes. Since it depends on the screen being on, pressing this will also turn on the screen if it was off. Pressing it again however, won’t turn off the screen.
  • edited October 2014
    Hi ohyeahar,

    So this is the "i" button for making setting changes. It does not work.
    At the opened screen I can see the settings, but when I push the i button it does nothing. If I half press the shutter button the screen turns off. When I push the "i" button the screen turns on. I think it means that the "i" button works. If I push it again it does nothing (cannot change the settings on the screen).
    Have I locked it somehow?
  • edited October 2014
    It still sounds like your camera is performing normally. Like I said before, pressing the "i" button doesn't turn off the screen. For that, you need to press the "Info" button.
    To make setting changes in the Info Menu, you need to press the "i" button and then use the directional pad to move the selector around. Then use the "OK" button to make your selections.

    This is where you make changes to:
    Image format, image quality, image size, WB, ISO, release mode, AF mode, AF area, metering mode, Active D-Lighting, bracketing, flash mode, flash compensation, exposure compensation, and Picture Control
    (I hope you weren’t making these changes for the past 2 years by drilling deep down into the main menu! You might be very angry to know that you can do it this way!)
  • edited October 2014
    Just in case saying much the same thing in multiple ways helps I add:

    On my D3200 I generally have the display off. It lights when I turn it on, and goes off as soon as I push the shutter button. The "info" button behind the shutter turns it back on when needed, and it goes back off when I push the shutter button. This is an option from the menus, as ohyeahar says; it's to conserve the battery. I also just like it less busy.

    If the screen is off, the "i" button to the left of the screen first simply turns the display on. It requires a second push of the "i" button to initiate the "i" display. This is a different screen in which the options available are shown, and the one currently active is highlighted in yellow. The usual display items and any that are disallowed in the mode you're in, will be grayed out. The last function used will be lit, and you can return to it by hitting the "OK" button. To choose another, you use the wheel to move the highlight, hit OK to enter the function, use the wheel to change it, hit OK to set it.

    Once the display is lit either by menu setting or button pushing, the "i" button will toggle between the "i" menu and the regular display. Pushing the shutter button will return you to the default state. If you have auto display off in the menu, the screen goes dark. If it's on in the menu, it will revert to the regular menu (e.t.a I meant the regular display screen, sorry about sloppy language).

    The next time you enter the "i" menu, the function you last used will be highlighted in yellow.
  • edited October 2014
    So if I push the second "i" button, the camera doesn't initiate the "i" display to make the settings?
  • edited October 2014
    I'm looking here at the D3200, which is similar, I think. I'm not sure what you mean by the "second 'i'" button. There is one "i" button and one "info" button, whose function is not quite the same.

    If you push the "i" button that is to the left of the display screen, it should open the "i' menu for changing settings. If your display is already on, the first push of the "i" button will open the "i" display in which you should see the settings available, with the last one used highlighted in yellow. If your display was off, the first push will light the regular display and the second push will open the "i" display. The "info" button behind the shutter button, which toggles the main display on and off, will not open the "i" display. Once the display is lit, the "i" button will toggle between regular and "i" displays. To turn it all off, you use the "info" display.

    To actually change the settings, you use the multi-selector to move the yellow highlight, and the OK button to enter the setting for what is highlighted.

    Edit to add: It's still not entirely clear here whether you have a malfunction, but if your display is on, and you toggle the "i" button, one of the two screens should show some setting highlighted in yellow. If this is not the case, then perhaps you do have a malfunction. If you do have a setting highlighted in yellow, try pushing the "OK" button and see if something happens.
  • edited October 2014
    Thanks Bruto, I wrote wrong.
    What I meant to write is that the second push of "i" button does not change the display to settings mode.

    So my problem is:
    - If my display is off and I push the "i" button, the display lights up.
    - If the display is on and I push the "i" button, the display stays in the regular display. It does not go to the "i" display and I can not change anything.
  • edited October 2014
    That doesn't sound good. I realize the D5100 differs some from mine, but what I've read suggests that the only real difference, apart from what's on the menu itself, is where the button is located. As far as I can see, it still should toggle the display between regular and "i" displays. I suspect that there's a button malfunction, as I cannot see any setting that would disable the button.

    On the D3200, the "i" button also toggles the "i" display on and off in live view. Is there any chance it works in live view on yours?

    Can you still get into the menus? At least everything you can change is duplicated there, so you can still use the camera, though not as conveniently.

    About the only other thing I can suggest, which is a long shot indeed, would be if you can get into the menu and do a complete reset. Then perhaps if there is a feature we've missed, it might revert. Of course all your other settings will be reset too. I'd also try pushing the "i" button and wiggling it a bit, in the hope that some crud might be dislodged.

    Otherwise, I fear it may be time for service.
  • edited October 2014
  • edited October 2014
    I have a D5100. If you are shooting in any of the automatic modes, you can only change a few things, but in the MASP modes you can change everything. In auto screen settings, push the "i" button once and the screen will change colors. Then use the ok button and up and down arrow.
  • edited October 2014
    If I read @glodo right, his display does not change at all. Even when most of the choices are grayed out, the "i" button should change the display and give you a yellow highlight. On mine, if the last option I used is grayed out, the highlight always returns to the top of the list "image quality" setting, which is available in all modes.
  • edited December 2014
    @glodo, my D3200 suddenly started doing EXACTLY the same thing as you are talking about here. I found that for some reason, if I operate the shutter mode switch, select the same shutter mode I was on, and then hit OK, it returns to normal (at least for a while). I think there's a hardware issue, and I'll probably be taking mine back if it happens at all again. I thought this was an interesting development, as the malfunction matched yours completely: stuck on RAW, no arrow key movement, no OK button action, and although the menu opened, nothing moved or worked there. As I say, it seems to have recovered when I worked the shutter mode button, but I'm not sure I trust it to keep working.

    Edit to add: every time I turn the camera off and on again, the problem returns, but working the shutter mode button corrects it temporarily. I'll probably take it back soon for service, but it seems to be working all right in the meantime.

    A further edit to add: it seems to have recovered some now though I'll have to keep an eye on it. I do note that the instructions mention a potential problem with static electricity occasionally messing up the controls. For the moment, mine is working after having a series of recurrences of the problem. Each time it was resolved either by using the shutter release mode button or by pushing the "i" button again. Every once in a while I have been sneaking up on it to see if it will misbehave again. So far so good.
  • edited December 2014
    Just a little update. My D3200 began misbehaving more consistently, so I took it to the local dealer, where it refused to misbehave at all, and it has not done so since. The dealer suggested that they can't or won't fix a problem if they can't make it happen there, and that if the problem is dirty switch contacts it is not under warranty anyway. So I'm back to hoping either that it fails completely and soon, or has cured itself. It still might be a matter of ambient static electricity or dust in the switches, but I would advise anyone with a similar problem to try all the switches on the back in the hope that one will unlock it. The shutter actuation mode switch on mine has worked every time.
  • edited January 2016
    Hi @glodo, I have the same problem with my D5100. My "i" button doesn't work, and I can not use the info display. Could you please tell me what you did about it?
    Thanks!
  • edited January 2016
    Have you tried all the other buttons to see if one will wake it back up?

    The [i] button will not do anything if another button is being pushed at the same time, and it's possible that there is a stuck or dirty button somewhere or some other oddity that makes the camera believe another button is being pushed.

    When I had this problem, as noted above, the only back button that functioned correctly was the shutter mode button. When I opened that, the screen lit up and the controls worked, and when I left the shutter mode, the other buttons worked again. I would try every button on the camera, and see if anything scares it back to life.
Sign In or Register to comment.