Howdy, Stranger!

If you're just starting out in the world of photography and want to learn how to get the most out of your camera, then this forum is your new secret hangout spot!

Take better photos today with my Canon T2i Cheat SheetsCheck 'em out!

Lock Up

edited April 2013 Posted in » Canon T2i Forum
Hey there. I have owned my camera for a couple years without a problem and I absolutely love it. However, this Christmas my husband bought me a Canon 50mm lens and after only a short amount of pictures, my camera started freezing up. It acts as though the picture took but it just locks up and gives me a continual red light until I take the battery out. I tried finding a fix online with no luck so I just put it away for awhile. Got it back out tonight and thought I'd try again and to my surprise it worked, for about five more pictures. I have tried reformatting the card, removing the card, resetting the camera settings, checked the battery, etc. Has anyone out there had this happen and got a fix? I don't have anybody local to take a look.

Comments

  • edited April 2013
    Also just noticed I can't use the live view function (although enabled).
  • @Autumn - Couple questions...is the LCD displaying an error message? Are you using the built-in flash? Does it lock up when using your 18-55mm kit lens?
  • edited June 2013
    This is the second time my camera has locked up. The only thing I can shoot is video at the moment. No busy, no error, just green flashing light like it wants to work, but cannot. Used a new card, took out battery, battery is fully charged; I give up.
  • edited June 2013
    If you can shoot video but not take picture, could it be that the mirror is locked up? Have you enabled the mirror lock up custom function maybe inadvertently? Have you tried with another lens?
  • edited June 2013
    The funny thing about the camera is I was shooting pictures at the time it froze. I messed with it a little last night and the body works without a lens. Swapped lenses and no joy.
  • edited June 2013
    Woohooo, thanks I got it fixed. The ae/af lock turned itself on. I turned it off and it appears to work. Must be a software glitch in the camera to turn itself on while shooting. The settings are hidden deep into the custom features.
Sign In or Register to comment.