Howdy, Stranger!

If you're just starting out in the world of photography and want to learn how to get the most out of your camera, then this forum is your new secret hangout spot!

Screen Issues

edited November 2012 Posted in » Canon 60D Forum
I went to take pictures yesterday and for some reason, when I push the shutter button to focus my camera, the screen where all my settings are goes black. My settings wont come back until I push the Q button and then it goes black again once I take a picture. Does anyone know why this is happening or how I can fix it? I really need my settings to stay on my screen when I push the shutter button down. It's annoying having my screen go black, especially because I can't see when I'm changing my focus point anymore. Please help!

Comments

  • edited November 2012
    Hi,
    Oh dear you are using live view mode aren't you? With Quick mode selected, the mirror has to swing up out of the way in order to take the shot, that is why your screen goes black.
    Have you tried using the viewfinder? You will find that your settings are displayed along the bottom until you take a picture. You can also see the AF points if you want to change them and a host of other features. Using the viewfinder is really the best way to use a DSLR. Although live view does have some uses, for general picture taking it is best suited to lightweight point and shoot cameras.
  • edited November 2012
    Hey!
    No, I'm not using the live mode. I actually really don't like live view mode. I have it set where I look through the view finder to take the pictures.
    When I want to see the focus point and change it, normally that would show on my screen after I focus the picture, but that is also gone and I can only see it through the view finder. I need my settings back on my screen after I push the shutter button down to focus the picture.
  • edited November 2012
    Hi again,
    My humble apologies. It is just that the symptom you described is a classic feature of live view in AF (quick) mode. However, I'm now slightly confused because you mention the focus points on your screen have gone and you can only see them in your viewfinder. Then you mention the screen again. So what I would like to know to try to help is what is going black, the screen or the viewfinder? If it is the screen, then this could be a problem with the LCD. If it is the viewfinder, then it could be a problem with the reflex mirror sticking. There are other possible causes as well.
  • edited November 2012
    Sorry, it's the screen. What happens is I can see all of my settings on the screen, and then I push the button down to focus the lens (the same button you push to take the picture) and my screen goes black and my settings wont come back until I push the Q button. Then they are once again gone as soon as I push the button down to take the picture.
    Normally when I push the button to focus my lens my settings stay on the screen and even after I take the picture the settings would be there. Now when I take the picture the screen shows the picture quickly and then is back to black again.

    With the focus points I can see them through the view finder, but once again normally when I push the button on my camera to change the focal point I can see that information on my screen. It is also now gone and the screen just stays black and I have to look through my view finder and watch the little red button to change the focus point.

    It's so annoying! I don't know why it's all of a sudden doing this, but I'm hoping it's an easy fix.
  • edited November 2012
    I have never heard of this showing before the shot is taken, only after.

    Can I ask which mode you are shooting in ( manual, auto, av)?

    The only thing I can think of is to hit the review button and then scroll through the info button even though this is to review the photo just taken. Go into the menu and extend the review time if the photo is disappearing too fast.

    I wish I had my camera and manual here at work so I could figure it out.

    Sorry I could not be of more help.
  • edited November 2012
    I shoot in manual. I have had this camera over a year now and it has always showed the settings on my screen where I can scroll through and change my settings before and after the picture is taken. Now it's all gone and my screen is just black.
  • edited November 2012
    No, maybe not.

    I have gone through the manual and asked a friend and neither of us know how you could have seen the info before the shot was taken unless you are in live view.

    My friends actual response was along the lines of why would they put that info coming up on the screen when you are looking through the viewfinder. It means you have to take the camera away from your eye when all the info you need is in the viewfinder.

    This is all we can come up with unless there is something we are missing or not understanding.

    The only other thing we could think of is to take it back to the shop and see if they can help you.
  • edited November 2012
    Hi Sparkz,
    Unless anyone comes up with a solution, I think this is a repair job. I have spent the best part of a day trying to replicate your problem without success.
    When you press the Q button all the information is there and the ability to scroll through and change things. The info stays there while you focus by half-pressing the shutter, but at the moment the shot is taken the screen does indeed go black and then returns to the standard screen. In order to change things you need to press the Q button again. This is how the camera should work. But in your case, this is not happening. I'm still leaning towards a faulty LCD, but I'm not an engineer so don't quote me on that.
    Regards
  • edited November 2012
    I totally understand what sparkz47 is describing because I have the same problem with my camera. I wanted to ask the question here but I just wasn't sure how to phrase it for everyone to understand the problem. Thanks for explaining it sparkz47. The same thing happens with my camera when I press the shutter button to focus my camera. The screen where all my settings are goes black. The settings will not appear on my screen until I press Q. When I take the picture, the screen shows the picture quickly and then it's back to black again. It never used to be like that, it only started about six weeks ago. I just thought maybe it's normal. I will take my camera where I bought it and maybe they can explain why.
  • edited November 2012
    I think the problem is the confusion between the INFO button and the Q button. You can fix your problem by just using the INFO button. Try pressing the INFO button repeatedly and you should see the screen cycling between 4-5 different kinds of display, including a blank display. Go ahead and keep pressing the INFO button until you come to the full info screen that you desired and stop. Your problem should be solved then. Do not press one more time because that's the blank display option, the origin of this headache.
  • edited November 2012
    Additional information is on page 266 of the manual under INFO button functions.
  • edited November 2012
    Hi lamson, thank you so much for the advice, it worked. I went to Q then pressed info as you said and now it's working as it should. @sparkz47 u might want to try that.
  • edited November 2012
    maiMelissa, I'm glad I could help. But, to clarify, the Q button is for quickly changing your settings. Our current issue is only with the INFO button, just for displaying your settings. You can ignore the Q button for now if you do not intend to change settings for your next shot.
  • @lamson
    Well done lamson. I'm kicking myself for not spotting that. Just goes to show how the little things can be so easily overlooked. Good work!
  • edited January 2013
    Hit the info button three times, that should do it :)
  • edited March 2013
    I have the same problem and I can't figure it out. I deliberately hit the info button this weekend to hide it at night but I can't get it back!

    It shows when I hit the q button, but when doing the info button, I get black screen and a screen of a vertical list of settings. Is there a way to reset all settings on this camera?
  • edited March 2013
    Actually I just reset all settings and it is still the same!
Sign In or Register to comment.